Wrong data showing when importing Binance data through excel file

Hi,

I just started and tried to import my Binance trading data using an excel file directly exported from Binance. Any data for which fees have not paid with BNB are fine, but any trades for which it does it goes berserk. It assumes BNB was traded and the other coin will show as unknown. I cannot use API as my account is closed. Any help or a fix is appreciated.

Thanks,

pkes

What seems to go wrong is it reads the “market” column (second column) in the csv file as one coin, and then it trades it against the last column (“fee” column). When trading the BTCUSDT pair it’ll register as an unknown coin “BTCU” , and it trades against BNB (that is what the fee was paid with). Please look into this error, it seems like a big flaw.

It is suggested to connect Binance via API, otherwise, you will have to manually reformat their csv files into Accointing’s format that can be found in the Accointing Template.
Here is a video how to connect via API: How to Connect Your Binance API to ACCOINTING.com - YouTube

Thanks, I would connect it via API but cannot as the account is closed. I only have the trading data in csv format.

There is an option in Accointing to upload the Binance csv files in their native format, this is what I used. Is it known to not work properly? Maybe it can be removed or fixed otherwise, since that is confusing.

Oh, I am sorry that I missed that your account is closed.
We will need a copy of your CSV if you do not mind. Alternatively, you can take a screenshot of an example of your spreadsheet and I may be able to help your format it correctly.

I’m going to need you to help me out with the following:

  1. Account details
  2. Screenshot of the error you received
  3. Wallet/Exchange you were using when you encountered this issue
  4. Exchange or Wallet API keys, Wallet Address or CSV used to try to replicate the error
  5. Link to this community post

Please send all of this to support@accointing.com and we will try to help you out as quickly as possible.

Thank you, I have done so now!

1 Like

Consider this:

This topic was automatically closed after 4 days. New replies are no longer allowed.