Token Not Giving Cost Basis

For some reason the cost basis is not showing for this coin.

I tried using a swap transaction and i could not get it to give me a cost basis so i converted it to “Order” transactions instead but it still does not seem to work.

According to the picture above, everything should be working but it still isn’t giving me an average purchase price according to the overview in the web app.

Have you tried refreshing your metamask?

Yes, i have refreshed my wallet and now have a new transaction with the same problem.

The following swap transaction wont give a cost basis. This was the same problem as with the Milk Token earlier, changing the transactions from a swap to a single Order transaction does not fix the problem.

We are at an interesting predicament. I do not think CMC keeps track of the price of the token before they supported it. Your transactions if from like 2 hours before they supported the token. If you changed the time, will it show a cost basis?


MILK was supported on 5/5/21 at 10:30 AM

I checked and both coins were purchased after being listed on CoinMarketCap. I think I found the real reason for this issue though. Its a problem with the price being so small its value isn’t being given from CoinMarketCap, despite having a graph for the actual value.

As shown in this picture, this coin used to have a current value but not now no longer does.

as shown on this picture, its value is so low that it only shows its value as <$0.00000001 even though it shows on the chart as around $0.0000000046.

So what that means is the cost basis for these coins was never given because the value was below $0.00000001 which seems to be the smallest value a coin can have. While i don’t i don’t know if CoinMarketCaps API provides the actual value or not, I would believe it is possible to fix the problem since their graph is still working somehow.

2 Likes

Good point. I am unsure how the API works, however, the value may just be too small for Accointing’s rounding system that it actually rounds to $0.
I mean you do not even have a penny here:
NCC


MILK

But when I own enough MILK to bring a value above a $0.01, I get a value.
image

I believe everything is working as intended :slight_smile:

Am I good to close the post?

You did your math wrong because I have 77 billion NCC, not just 77 (notice the “B” at the end of the number, that’s what it means) Accointing is obviously getting its total value by rounding the cost of each coin to 0. So no matter how many coins I have, it’ll always equal 0.

This is the same for the milk token when I purchased it.

So this needs to be filed as a bug report and not closed.

1 Like

I see, my bad, 77B
image
It imports the data correctly when I have 77,000,000,000.

Let me ping @Rod

1 Like

Issue 1: NCC
The issue with NCC not having a cost basis has been corrected by what you suggested. Like you said, it was purchased minutes before it was being tracked. I fixed it by changing the time to when it started getting tracked. The only issue with this now is its total value currently is not listed on the overview section of the web-app. While it might fix itself, it currently is an issue.

Screenshot from the overview section of the web-app that shows the missing total value:

Issue 2: MILK
The issue with MILK not having a cost basis is still an issue. The problem here is that it was being tracked at the time i bought it, 66 hours after being tracked, and because of that it doesn’t have the same problem as the first issue had. To complicate things more, i made a second purchase of MILK today and it does not have this issue. But since Accointing only has the cost basis of the second purchase, it is calculating the profit/loss only based on that amount.

Things i’ve already tried to solve this issue:

  • Add 5 minutes to the purchase time, which didn’t work since it was already tracked at that time.

  • Changed the “Swap” transactions to “Order” ones, which didn’t do a thing except consolidate transactions.

  • Refreshing my wallet, which didn’t work since i’ve refreshed it plenty of times since to add my new transactions.

Screenshot of the date MILK started being tracked on CMC:

Screenshot of the first purchase of MILK that does not have a Cost Basis:

Screenshot of the second purchase of MILK that has a Cost Basis:

Screenshot of the Overview section of the web-app that shows the incorrect profit/loss based only on the cost basis of the second purchase:

Hey! I’m sorry to hear that. I’m going to need you to help me out with the following:

  1. Account details (BSC address)
  2. Screenshot of the error you received
  3. Wallet/Exchange you were using when you encountered this issue
  4. Exchange or Wallet API keys, Wallet Address or CSV used to try to replicate the error
  5. A link to this page

Please send all of this to support@accointing.com and we will try to help you out as quickly as possible.

Hey @alantbarlow can you send your BSC address to our

I sent the requested info to support, will report back here when the problems have been solved.

1 Like

Thank you very much :slight_smile:

Hey @alantbarlow are we good to close the issue?

This topic was automatically closed after 6 days. New replies are no longer allowed.