Metamask Sync Issue

When syncing with Metamask, the latest ETH transaction is not being picked up. Transaction is around 3 hours old.

Hey @IsaacWhitlock are you still having the issue?
What wallet / exchange are you using?
A screenshot would be wonderful.

I’m also having sync issues. No new transactions imported since 30/6 early morning.
It also seems that now Metamask is syncing the BSC chain transactions which it wasn’t doing before. Not sure if something changed in relation to that which is causing the issue?

Hi Matt,

Thanks for responding. :slight_smile:

Not too sure what a screenshot would add but can’t get one now. As per the title, this was an issue with a Metamask wallet.

Clicking the refresh icon would get the spinner and progress bar but, when complete, no new transactions would appear.

This has worked up until today.

I was still having the issue as of 9am this morning. Fixed it by deleting the wallet and starting again. Not the best option but it worked.

Eurion, not sure if the same solution will work for you or is viable.

Cheers

IsaacWhitlock

1 Like

I am also having this issue. No transactions from today will sync from ETH Metamask.

Yeah, I guess it would fix the issue, but I’m not looking forward to having to classify everything again. There’s quite a bit of transactions in it (including comments for purchased NFTs - ie. name of NFT attached to record), which would really suck to have to recreate.

I would expect Accointing support to first clarify if there is no other option before I nuke the wallet and start over. :frowning:

I tried to refresh the connection but this didn’t work. When I added another copy of the wallet, it does show the transactions and correct balance. I noticed it’s now also possible to add Metamask on the BSC network (which wasn’t there before? or I missed it). I have some BSC transactions showing up in my original Metamask (eth) wallet on Accointing, so I’m wondering if Accointing recently added this feature and that somehow messed up my original synchronization :thinking:

Same issue for me here as well. Not picking up any transactions in the next few days. Deleting and re-adding might work but reclassifying 400 transactions isn’t something I want to do…

I was lucky in that (nearly) all my transactions were mining payments so re-classification wasn’t an issue.

Thanks for bringing that to our attention. I have created a bug for it and will keep you posted once this is fixed. I appreciate your time and patience.

Do you know who could fix it? You can earn $5,000 by referring someone here: ACCOINTING.com Referral Program: Earn $5.000! - We Are Hiring - Accointing.com

Yeah Metamask wallets are really messing up. The ETH wallet is pulling in BSC tokens and not updating ETH tokens. And BSC wallet isn’t pulling in correct numbers.

Any idea on how long it will be before metamask imports will work? This is a big issue for me personally, and I assume many others…

We are still working on it, but as of now, here is how you can add it, in the near future we will push another update for metamask :smiley:

image
Name it what you want, then click the fox logo on the bottom

Then your Metamask extension will open

Removing and re-adding the wallet will require me to classify somewhere in the range of 500 transactions… again. Is this not something that will be fixed without remove/re-add wallet?

Do not remove your wallet, this is just how to import your wallet while we are working on the issue.

So Metamask updated today and pulled in new transactions. It also broke the classification and links between about 1/3 of my total transactions which now all show “Unknown receiver” and “Unknown sender”. I’m guessing I’ll have to manually go back and redo all those transactions again.

I’ll go back and fix the transactions one more time but if something like this happens again I’m done here and will have to find a new tracker for tax purposes.

Trying to reclassify my transactions and my internals are unable to classify at all now. Just get “Failed to update”.

image

Hey @lagsmoke we are still working on Metamask as we speak.
Alternatively you could copy and paste your ETH address and BSC address, instead of doing the Metamask intragration.


Did this ever get fixed? I have only been trading a couple of months and am new to Accointing. My balances in Accounting are wildly inaccurate. Maybe because they are all shit coins? I have had a lot of garbage dumped into my wallet that I set to ignore, but my balance is still inflated by billions!