Celsius Spark Balance & Stellar Wallet API

Hi,

I got two issues:

a) Celsius: On 2020-12-12 (afaik) there was an airdrop/fork of “Spark” for every XRP holder.
Recently the celsius api started showing that balance, but Accointing can’t classify it as airdrop or fork, because it doesn’t see when the Spark first appeared on the celsius account. So we got a balance without ever receiving something. The coins are just suddenly…there.

b) My Stellar wallet, which is API/public key connected, won’t update. “An error occurred”

Best regards

Wolf

  1. Thank you for that information, in that case, you please go to your full data set and create a manual transaction and classify it?
  2. Can you DM me your public Stekkar wallet?

That might sound like a really dumb question but: How??
I’ve spent the last 10 minutes trying to find a way to dm you. It seems there should be an envelope-symbol when I click on an avatar. But there is none…at least I don’t see one.

Hi Matt,

Due to my inability/incompetence to find the DM button in the forum……why not use email :slight_smile:

Here you go (stellar wallet):

GBOWQ5KK532DZBEOX73BUA75MIUI65NS3PTVYPBYKOT2GESKTYY4NNUG

Thank you for that! We do have an email option as well, but I am trying to limit the number of emails I have forward to them, especially if I can do it if I know the information :slight_smile:

I was able to import your wallet and return a balance

Can you please try again today, I believe our team has fixed the issue :slight_smile: ?

Hi Matt,

sorry, but…no, it’s not fixed. I still get the same error message “es ist etwas schiefgelaufen” (something went wrong).

Hey @WolfB , can you send me a screenshot of your error? It is working for me.

Try again, we just published another fix :smiley:

That definetly did something and we ALMOST got it :slight_smile:

Now…besides the balance…I indeed get the transaction history of that wallet.

Just one thing I can’t wrap my head around. It seems a few weeks ago I received some Shiba Inu on that wallet (obviously an airdrop or similar…since I never bought any).
The strange thing is…I see the transaction:

But the wallet itself says: balance = zero:

What’s going on here?

This is what is going on

In the frontend we commonly round prices (esp. fiat representation of values) to 2 digits. On the internal side, we keep a precision of 8 decimals though. This is relevant to for the tax calculation and is precise enough. For coin quantities and values, we currently have a maximum of 9999999999999.99999999

First of all Thank you Matt for your support!

In case of the dollar value I totally get your explanation. But why is the count zero?
As far as I understand your answer the interface should display 150 Shib at a value of 0,00 dollars / euros…whatever.
But what it says is: zero shib at a value of 0,00 dollars

Either I got an airdrop of 150 Shib…then the count should say so.
Or I didn’t get an airdrop of 150 Shib…then there’s a transaction that shouldn’t be there.

It can’t both be true