Can't add Polygon (error)

Hello, I’m having trouble adding my assets on Polygon network. I found the Polygon option listed in adding wallets, but when I provide the address from my ledger (I use across 3 different smart contract networks), it says error and does not connect.

How do we proceed from here?

Hey gecrypt,

you will have the same problem with Cardano in the moment and this issue is known. The devs investigate the problem and working on a solution.

2 Likes

Working on it now.

3 Likes

Any update on this issue? Its been a week and still cannot add my polygon address.

1 Like

Polygon should be up and running :smiley:
Please tell me if you are experiencing an error

Still the same problem …

yep, still the same error with cardano and polygon

2 Likes

Same error for me with Polygon, too.

1 Like

Obviously it doesn’t work yet. Can you give us a status update on this issue?

I will report that we are still having issues. Can someone try again, there was a fix pushed out last Friday.

Hi Matt. I tried it now. Unfortunately still the same problem: “Something went wrong”…

1 Like

Still not working for me either. Same “Something went wrong” message.

1 Like

The same is happening for me as of August 17, 2021.

Cardano (ADA) is still saying “Something went wrong”.

1 Like

1 Like

Thank you, we are currently working on Polygon and ADA right now.

I am (frustratingly) getting exactly this too. :frowning:

Polygon / Matic wallets are now working!!!
Send me a list of unknow currencies and I will add what is available on CoinMarketCap!

Ok, Polygon wallet works now.

1 Like

Cardano is still not working for me.

Hooray! Polygon is working.

1 Like